Tricia S.

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • in reply to: Issue with new class #30327
    Tricia S.
    Participant

    What I put in my custom CSS seems to be working. I haven’t had any issues with it combined with your new casc file. here is the code one more time:

    
    
    .dffs_req_and_tt{float:left;
        z-index:1;position:absolute;
    }
    .dffs_req_and_tt_wrap {
     display: unset!important;position:absolute}

    Thanks again!

    in reply to: Issue with new class #30152
    Tricia S.
    Participant

    It works perfectly if I add this to the to the loader file:

    
    
    .dffs_req_and_tt{float:left;
        z-index:1;
    }
    .dffs_req_and_tt_wrap {
     display: unset!important;}

    Except when its in a dialog box. Then I still have some issues.

    
    
    .dffs_req_and_tt{float:left;
        z-index:1;position:absolute;
    }
    .dffs_req_and_tt_wrap {
     display: unset!important;position:absolute}

    I need to test it a bit more.

    in reply to: Issue with new class #30141
    Tricia S.
    Participant

    I was in the middle of typing this up when I saw your latest response:

    I have a workaround but its not Ideal. At least I don’t require a ton of fields.
    My work around is to add this in my loader:

    
    
    .dffs_req_and_tt{float:left;
        z-index:1;display: none;
    }
    .dffs_req_and_tt_wrap {
    display: unset;}

    and then before the my HTML Heading I added:

    <div class="dffs-formvalidation" style= "float:left;z-index:1;" >&nbsp;*</div>

    Let me know about the update and as always thank you for all the help! Sorry if we took the long way to get there.

    in reply to: Issue with new class #30131
    Tricia S.
    Participant

    Sadly I updated it Yesterday so All those Screens shots are from the 5/10 version.

    in reply to: Issue with new class #30120
    Tricia S.
    Participant

    Here is the readonly after switching between tabs

    in reply to: Issue with new class #30114
    Tricia S.
    Participant

    Please see the following attachments.

    The files called Cascade inspect 2 Is the goal and it reflects both changes:
    .dffs_req_and_tt_wrap{display:inline block;}
    and
    .dffs_req_and_tt{display:none;}

    It seems that
    .dffs_req_and_tt{display:none;}
    Work fine by itself as well.
    But it done not Work for Switching tabs when there is a readonly set on a Cascdading Drop down. I will post that image in the next comment.

    in reply to: Issue with new class #30096
    Tricia S.
    Participant

    Yes All Fields Have heading and No labels are shown.
    Its the

    
    
    .dffs_req_and_tt_wrap{
        position:absolute;
    }

    I have tried to push stuff out to the spjs_selected to counteract it but it won’t give.
    Some testing version attached. Including ones where I unhid the field labels.

    in reply to: Issue with new class #30089
    Tricia S.
    Participant

    Hi Alexander,

    I also attempted the position absolute and its messed with the CCDW. See After code image.

    I also recreated the Tab issues. See other images attached.

    Thanks,
    Tricia

    in reply to: Issue with new class #30075
    Tricia S.
    Participant

    I removed all my custom CSS related the dffs_req_and_tt.
    The items in red are all from a CCDW. Included the readonly which is set by an on load rule.

    Attachments:
    in reply to: Issue with new class #30069
    Tricia S.
    Participant

    Hi Alexander,

    I’m pretty sure its the latest version. Version screen shot include.

    I included some front/back end shots. My field labels tend to be hidden.

    I am on the 4/15/2020 version. Is it something I should update the may version?

    in reply to: Issue with new class #30035
    Tricia S.
    Participant

    Ran out of attachments. Here’s what the styling looks like with my custom CSS.

    Attachments:
    in reply to: Bugs-Heading and Rules Affected #29151
    Tricia S.
    Participant

    Thanks Alexander!

    I tend not to use the the real Field labels because I don’t uses spaces and special characters to avoid the _x0020 in my FIN, but my users want the labels to be readable.

    I know I could name them and then rename them but Switching between the display name and FIN is just a pain. and can change depending on what you are in. I’d rather just do pretty in the front UI and business in the back.

    Noticed in the CSS file the cursor is still set to default for read only, but I couldn’t find where the blue box for read only was coming from. Idk If this is more efficient or not, but before the toggle was added we did:

    
    
       input:disabled + .slider {
      cursor:not-allowed;
    }
    input:disabled + .slider:before {
      cursor:not-allowed;
    }

    and then instead of readonly I did

    document.getElementById("Related_ac2e01da-5fc4-4818-9ee1-a3cafbf03a51_$BooleanField").disabled = true;

    They like that it showed the toggle but was very clear you couldn’t click on it. Not something I’m expecting in an update just wanted to put it out there in case it was helpful.

    My users love the toggle so thanks for adding!

    in reply to: Var CAML Broken? #29063
    Tricia S.
    Participant

    Thanks Again Alexander! I have done it before. Just can be a bit of a pain when you have that nice UI tab I could use instead. Thanks for adding to the next release! I’m really looking forward to this next release now. 🙂

    in reply to: Var CAML Broken? #29058
    Tricia S.
    Participant

    Thanks Alexander,

    While on the Subject of vars, Can we use the {var:name_of_Var} in the “BaseUrl of the list” on the Cascading dropdowns?
    I reviewed the change log and only found where it could be used in the list values.
    I am finding that having a var for the Site here would be extremely helpful.

    Thanks,
    Tricia

    in reply to: Var CAML Broken? #29013
    Tricia S.
    Participant

    I’m Not using any formulas or Functions yet. In my custom JS I just have:

    var myCAML = “<Value Type=’Integer’>1</Value><Value Type=’Integer’>4</Value>”;

    I have also tried adding more quotes but it just made it worse.

Viewing 15 posts - 1 through 15 (of 24 total)