v0.9.0.16 has been published

Forums Modern DFFS v0.9.0.16 has been published

Viewing 12 reply threads
  • Author
    Posts
    • #36187
      Alexander Bautz
      Keymaster

      I have updated to v0.9.0.16 and added some new functionality. Read more details here: https://spjsblog.com/2022/10/10/modern-dffs-v0-9-0-16-has-been-published/

      Get the latest version here: https://spjsworks.com

      Please post any comments below.

      Alexander

    • #36188
      Brett
      Participant

      Hi Alexander, When I try uploading the latest few versions, my Site Collection app catalog is stuck on uploading 0 of 1, so I have to cancel it.

      If I use an older version like 0.9.0.0 it uploads instantly and dialog window displays Trust acknowledgement.

      • This reply was modified 1 month, 3 weeks ago by Brett. Reason: replace option doesn't work
    • #36190
      Alexander Bautz
      Keymaster

      I’m not sure what could cause that. Do you see any errors in the “App package error message” column in the app catalog list view?

      You can try using another browser (in case it was some kind of browser cache issue) or ask another user to try uploading it.

      Alexander

    • #36191
      Brett
      Participant

      No errors when I upload v0.9.0.0.
      When I attempt to upload v0.9.0.16, it’s stuck on 0 of 1 complete.
      Error in console displays: Failed to load resource: net::ERR_CONNECTION_RESET
      Full Console error attached.
      Hope that helps.

    • #36193
      Brett
      Participant

      Hi Alexander,
      Just a follow-up, when I extraced the App package and uploaded the ClientSideAssets folder to a doc library, 1 file failed to upload:
      dffs-command-set_e20ee710c94bda4b8391.js

      Brett

    • #36194
      Alexander Bautz
      Keymaster

      I’m travelling and won’t return home until Sunday, but will investigate it. Do you get any specific error messages?

      Anyone else experiencing the same problems?

      Alexander

    • #36195
      Brett
      Participant

      Hi Alexander,
      I’m just testing this on my own.
      From further testing, the file dffs-command-set_e20ee710c94bda4b8391.js file displays error when uploading it to a 365 doc library but a SP2016 doc library upload works.
      Also, when I pasted the code from dffs-command-set_e20ee710c94bda4b8391.js to a Beautify Javascript website, so it’s formatted correctly, the new file uploads to my 365 doc library 100% with no errors.
      Dev console error attached.

      Brett.

    • #36197
      Alexander Bautz
      Keymaster

      I have tested again now and cannot reproduce this behavior. I’m not sure this is relevant, but what browser (and build number) are you using and also what is the UI language of your Browser and SharePoint portal?

      From your screenshot it looks like you use Chrome, but just as a test can you try using Microsoft Edge to see if you get the same error?

      Alexander

    • #36198
      Brett
      Participant

      Hi Alexander,
      I tried Edge, IE11 and Firefox all have same error.
      It could be related to my Corp Intranet blocking something in the js file.
      Difficult to decipher the console log, seems like generic errors:
      Uncaught (in promise) ItemOperationError: plt.listviewdataprefetch.js:2:102687
      I’ve got v0.9.0.0 to play with, so it’s not too important.
      Thanks for checking anyway.
      Brett.

    • #36200
      Brett
      Participant

      Thanks Alexander,
      I tried that rebuild with same result.
      I have found it’s something to do with my company’s intranet blocking something during the upload.
      When I logged on to my dev 365 personal site and uploaded from home network, it uploads fine, no errors.
      So when I Log on to the same 365 dev site from company’s intranet, the upload error occurs.

    • #36201
      Alexander Bautz
      Keymaster

      Thanks for the clarification. I’m not sure what could cause this issue, but maybe it is a “false positive” caused by the minification as you could upload it when you pretty-printed the file.

      I’ll try to update all “packages” in my solution to the latest version and you can have another go trying to upload it when I’m done.

      Alexander

    • #36204
      Brett
      Participant

      Hi Alexander,
      Please don’t waste any time on this.
      I was able to upload the v.0.9.0.16 package using my home computer connected to my corp 365 in the browser.
      Can you also delete this comment history as it’s not really a bug with your Modern App Package, it sounds like a firewall block on my corp network.
      Thanks,
      Brett.

    • #36206
      Alexander Bautz
      Keymaster

      Thanks for the update, I’ll leave the thread in case others have similar issues.

      Alexander

Viewing 12 reply threads
  • You must be logged in to reply to this topic.