User Field Read Only

Forums Dynamic Forms for SharePoint User Field Read Only

Viewing 3 reply threads
  • Author
    Posts
    • #34827
      Lahoud Halim
      Participant

      Hello,

      I am having a problem when i set a user field in the edit form to read only.

      the field will show as if he is empty but there is a value in this field if i disable the rule that make it readonly the value will show.

      i only have the problem in the edit form (the same field is set automaticly on the new form and its readonly and the value is shown)

      Thank you in advance
      LAHOUD Halim

    • #34832
      SteveE
      Participant

      Are you sure you changed the rule in EditForm vs. what you had in NewForm? My guess is that it is writing the field again and it is now blank. Have you tried to recreate the read-only rule in EditForm from scratch, only using the read-only assignment?

      A screenshot of the rule in EditForm would help.

    • #34834
      Alexander Bautz
      Keymaster

      I did have some problems with this in earlier versions – what version of DFFS are you running?

      You can also try to add a delay of for example 500ms in the Misc tab “Defer loading of DFFS” input.

      Alexander

    • #34836
      Lahoud Halim
      Participant

      Hello,
      i am currentrly using DFFS v4.4.5.27

      i added the delay of 500ms and the problem persists

      kindlt find the rule attached as an attachment

      Attachments:
      • #34840
        Alexander Bautz
        Keymaster

        It looks right, but are you sure you don’t have any other code or rules that remove the value? – try removing the people picker from the list of fields to set readonly – does it have a value?

        Alexander

Viewing 3 reply threads
  • You must be logged in to reply to this topic.