URL Query String Rule Changes Field value but doesn't trigger associated rule

Forums Dynamic Forms for SharePoint URL Query String Rule Changes Field value but doesn't trigger associated rule

Viewing 5 reply threads
  • Author
    Posts
    • #23386
      Brent Caudill
      Participant

      Hi Alexander,

      I am running the latest version – v4.4.3.58 and am having an issue with a “URL Query string key equals” rule.

      The rule is triggering correctly, and is configured to set a “Request Type” field.

      Another rule that evaluates the value of the “Request Type” is being triggered, but the actions of that rule are not working correctly when triggered by the “URL Query string equals” rule.

      The second “Request Type = ” rule is set to make a number of tabGroups visible. This is not happening when the URL Query rule triggers this rule by setting the value. The “Request Type = ” rule does work if I manually set the field value (choice field).

      Additionally, I tried to show the tabGroups directly in the URL Query rule in my testing, but it isn’t working in that scenario either.

      Debugging the rules shows them triggering correctly.

      Thanks,
      Brent

    • #23390
      Alexander Bautz
      Keymaster

      Hi,
      I did a test and cannot reproduce this behavior. Could you post a few images of your rule and tab configuration so I can verify that I’m recreating your exact scenario?

      Alexander

    • #23403
      Brent Caudill
      Participant

      Hi Alexander,

      Here are some images of the rules, tab and debug.

      Brent

    • #23432
      Alexander Bautz
      Keymaster

      Thanks for the screenshots. I have looked at them and cannot see anything wrong, but I’m wondering if you might have other rules that may interfere?

      If you have another rule that addresses the same groups of fields the changes in your current rule might be reversed.

      You can set the “No reversing of this rule” if you don’t want the actions reversed when the rule is not validated to true.

      Alexander

    • #23463
      Brent Caudill
      Participant

      Hi Alexander,

      Thanks for looking at this. I think it ended up being a rule, or rules, needing to be set to “Field Change” and not both “Form Load and Field Change” further down the config.

      Kind Regards,
      Brent

    • #23466
      Alexander Bautz
      Keymaster

      No problem, I’m glad you got it sorted.

      Alexander

Viewing 5 reply threads
  • You must be logged in to reply to this topic.