‘This form has no existing configuration’

Forums Modern DFFS ‘This form has no existing configuration’

Tagged: 

Viewing 2 reply threads
  • Author
    Posts
    • #36462
      Jorah Lavin
      Participant

      Good day, and thanks for building DFFS. It is an important part of my ability to deliver work for my internal SP clients.

      Over the last week, I built out a form using the new SPFx/Modern version and shared it with several coworkers yesterday. Today, the form has reverted to the default, and when I open it, I get the message ‘This form has no existing configuration.’

      I don’t believe that I have saved a config recently; is there any place I can look for deleted files or any other way to recover?

      Edit to add: This is V 1.0.11.0

      • This topic was modified 1 year, 4 months ago by Jorah Lavin. Reason: Added missing version number
    • #36465
      Jorah Lavin
      Participant

      Update: I decided to copy the configuration over from my SP2013 site, figuring that I’d at least have most of the fields and tabs I needed. After importing all three of the old configuration JSON blocks, I saved everything and set a Restore Point.

      This is where it gets odd.

      I closed out of the form and opened it again, and I was back on the config I’d built over the last week. Including my custom rules that don’t exist on the old site at all.

      I have no idea what’s going on, but I’m very pleased that I don’t need to rebuild everything.

    • #36466
      Alexander Bautz
      Keymaster

      This sounds strange. You can access the saved configurations by browsing to this list (but don’t manually edit the records): /Lists/DFFSConfigurationList/AllItems.aspx

      Let me know what you find – maybe there are some special characters in your list name that caused it to fail to load the configuration?

      Alexander

      • #36471
        Jorah Lavin
        Participant

        Interesting thought about the special characters in the list name; there was a slash in the name, although not in the original list creation name, so I’ve replaced that with a dash and we’ll see if the problem rears its ugly head again. Thanks!

      • #36475
        Alexander Bautz
        Keymaster

        Thanks for the feedback – let me know if it happens again.

        Alexander

Viewing 2 reply threads
  • You must be logged in to reply to this topic.