Rules opening wrong form, combination rules not working

Forums Classic DFFS Rules opening wrong form, combination rules not working


Viewing 1 reply thread
  • Author
    • #13525
      Keith Hudson

      I’m using the 2016-09-21 version of DFFS (see version details at end of this message). I am using a single SharePoint list to handle two separate forms (because they are closely related). FormA shows about 40 fields from the list, of which about 20 are required. FormB shows about 15 fields, of which 8 or so are required.

      When the New form first loads, users see only a tab that allows them to select the Request Type. If they select FormA, a rule fires to show the tabs related to FormA and set the FormA required fields. If they select FormB, a separate rule fires to show the tabs related to FormB and sets the FormB required fields. (The FormA and FormB required fields are different).

      If the user changes the “Ready to Submit” field to No, all the fields become Optional and they can save the form as a draft to work on it later before submitting it.

      HOWEVER right now, when the FormA rule fires, FormB is showing up instead of FormA. I have triple and quadruple checked my rules and cannot find any error in the rules.

      I have used IE11, Chrome and Firefox and see the same results.

      Any hints as to how to figure out why the FormA rule is showing the wrong tabs?

      Also, I tried earlier creating a combination of rules as follows. Rule 1 trigger: “Ready to Submit” = “Yes”. Rule 2: “Request Type” = “FormA” and “Rule 1 = true”. In rule 2, I stipulate all the required fields, but they were NOT enforced — for some reason, the combination of rules (which SHOULD have worked, if I understand the DFFS rule instructions correctly) simply did not work. I turned on debugging and confirmed that the rule conditions were met, but the form saved despite the required fields being left blank.

      Are there perhaps bugs in the version of DFFS I’m using??

      I’m on a tight deadline on this project, so I’m thinking I may have to roll back to an earlier version of DFFS, but I’d rather get this version working.

      I’m attaching a Word document with screenshots of the rules, the tab settings and the form that opens up incorrectly. Any help would be very welcomed.

      I’m using the following versions of DFFS files:
      DFFS frontend: 4.4.1
      DFFS frontend CSS: 4.19/4.19
      Autocomplete: 1.4.7
      Cascading Dropdowns: 3.528
      jQuery: 1.12.4
      Lookup: 1.1.5
      Resource Management: not loaded
      SPJS-Utility: 1.267
      vLookup: frontend v2.2.75

    • #13531
      Keith Hudson

      After some more testing, it appears I was misunderstanding the rule operation. I had set the FormB rule somthing like “when Request Type is changed from initial value” and inserted the target value in the value field, not realizing that for a change from initial value, ANY value will do. I changed the FormB rule to “when Request Type is equal to” my value, and it is working correctly.

      I still don’t know why my combination rules weren’t working before, but I’ll leave that puzzle for another day.

      Once again, a huge shout out to Alex for this great tool!!

Viewing 1 reply thread
  • You must be logged in to reply to this topic.