Rule & Email Notification Not Working

Forums Dynamic Forms for SharePoint Rule & Email Notification Not Working

This topic contains 9 replies, has 3 voices, and was last updated by  Alexander Bautz 1 week, 5 days ago.

  • Author
    Posts
  • #23181

    jShah
    Participant

    Hi Alex,

    We have a Form that requires user input. Using DFFS v4.4.3.48, there are rules setup that trigger the Email notification.

    The ‘EmailManager’ rule is –
    If this trigger ‘Manager Assigned [User]’ is changed
    Validates on Form load and field change

    Send or stop these Emails –
    managerEmail

    Under Email and Print we have this setup for ‘Email:managerEmail’
    Email Template ID: managerEmail
    To: {Manager_x0020_Assigned}
    Subject: WFVC {Request_x0020_Type} #{Request_x0020_ID} has been assigned to you.
    Body: {Manager_x0020_Assigned} has been assigned to {Request_x0020_Type} #{Request_x0020_ID} as Manager.

    Date Requested: {Request_x0020_Date}
    Category: {Issue_x0020_Category}{Request_x0020_Category}

    Title: {Title}

    Description: {Description}

    <hr>This message was generateed by RA notification workflow. managerEmail

    Notification when email has been sent:
    {Manager_x0020_Assigned} has been notified.

    This rule doesn’t work at all. When I add {Manager_x0020_Assigned} to another rule then whomever is the Manager receives the email. But this ManagerEmail Rule doesn’t work.

    Any Suggestions/Guidance would be appreciated. I’ve even deleted the rule, cloned a rule replacing the field then saving it. But still doesn’t work.

    • This topic was modified 1 month, 1 week ago by  jShah.
  • #23192

    AdamP
    Participant

    Have you tried turning on debug including the presave debug option under rules? When you change the field you should be able to see the rules trigger and when you click save see the emails generated (or not).

  • #23200

    Alexander Bautz
    Keymaster

    Hi,
    If you enable debug like AdamP described and post the results here I’ll do my best to help you sort it out.

    Alexander

  • #23202

    jShah
    Participant

    Hi,

    Yes previously I did turn on the ‘debug’ since this feature was available. In several scenarios of tests, I submitted as new item and also modifying existing item to change the ‘Manager Assigned’ field.

    The attachments show when I was testing during modifying an existing item. Hopefully this helps; I’ve been looking at it too long and unable to figure out. Thanks again.

  • #23213

    Alexander Bautz
    Keymaster

    Please update to the latest version of DFFS to see if the change I made in v4.4.3.53 makes any difference.

    Alexander

  • #23271

    jShah
    Participant

    Hi Alex,

    Sure will have to coordinate with our SCA on this site collection. Will let you know as soon as DFFS is updated to determine if it worked or not.

    Thanks again.

    Jignesh Shah

  • #23368

    jShah
    Participant

    Hi Alex, Quick Question how do I update my existing version of DFFS to v4.4.3.53 without affecting anything else? I’ve already installed DFFS on the site collection and other sites r using it. Just making sure how to go abouts.

    Thanks.

    Jignesh

  • #23475

    jShah
    Participant

    Hi Alex,

    After talking to the team, we decided to just add custom workflow using SP Designer instead. Thanks again. I have informed the team we should update the version for future reference.

    Thanks.

    Jignesh

  • #23477

    Alexander Bautz
    Keymaster

    Hi,
    I’m sorry you had trouble with this functionality. I have addressed some issues with “on-change” rules in v4.4.3.53 so if you like to have another go at using DFFS you should update to the latest version and check to see if it works better.

    Best regards,
    Alexander

You must be logged in to reply to this topic.