Not Working for all users

Forums General discussion Not Working for all users

Viewing 22 reply threads
  • Author
    Posts
    • #24579
      Joe Keyrouz
      Participant

      I have installed spjs on a subsite level inside a Site collection.
      I am a site collection administrator and the form is working for me
      but the DFFS create form rules are not working for the other users (even the site owner)
      i have given everyone the permissions on the list SPJS but the problem is still appearing

    • #24583
      Alexander Bautz
      Keymaster

      I’m not sure if this is what you meant, but all users must have read access to the SPJS document library in the root of the site collection if this is where it is located.

      Do you see any error messages in the console when you reload the page (hit F12 > Console)?

      Alexander

    • #24585
      Joe Keyrouz
      Participant

      Actually i have given access to all the users on the SPJS library but when they click on new item the forms is being loaded but no custom rule is occurring, like pop up message, filled field, hidden fields. it is only working for site collection administrators
      Concerning the console ; i have attached the errors displayed

      Attachments:
      1. joe_consol.txt
    • #24588
      Alexander Bautz
      Keymaster

      Sorry, but this didn’t help that much – could you take a screenshot of the console and show any red error messages? – preferably using Google Chrome because it shows better debug information.

      Alexander

    • #24623
      Joe Keyrouz
      Participant

      Hello, you can find the requested screenshot. THank you for your support

      Attachments:
    • #24631
      Alexander Bautz
      Keymaster

      Can you expand the error “Failed to load resource:…” with the little arrow in front of it?

      Alexander

    • #24633
      Joe Keyrouz
      Participant
    • #24636
      Alexander Bautz
      Keymaster

      Thanks,
      Unfortunately this doesn’t look like it is related to DFFS directly – do you use any custom js that tries to access the GRAPH API or call another service that the end users does not have access to?

      You can try adding another custom list without customizations and install DFFS to see if it works for the other users.

      Alexander

    • #24640
      Joe Keyrouz
      Participant

      The graph API is to get the picture of the connected user, it is not occurring with people having a picture but the DFFS error is occurring.
      The message before the graph error is a pure DFFS one The failed to load resource with error 500 . the jquery file is in the SPJS library
      https://engie.sharepoint.com/sites/secgen_engiegreen/rh/SPJS/DFFS/plugins/jquery.js

    • #24642
      Alexander Bautz
      Keymaster

      OK, I haven’t seen this error before. Can you open the Network tab in the dev tools (hit F12 > Network) and filter on “dffs” to see all the files related to DFFS – can you show me a screensot?

      Alexander

    • #24666
      Joe Keyrouz
      Participant

      Kindly find attached the .har file,
      i was able to check it on this site and filter on dffs
      https://toolbox.googleapps.com/apps/har_analyzer/

    • #24668
      Joe Keyrouz
      Participant

      I have uploaded the har file on
      https://drive.google.com/open?id=1DHYeDnU2oy_g1aRDJvIEQOrVhgdZQ6kW

      i was able to check it on this site and filter on dffs
      https://toolbox.googleapps.com/apps/har_analyzer/

      Thank you for your help

    • #24670
      Alexander Bautz
      Keymaster

      Thanks, I looked at the file and see that jQuery is loaded by DFFS like it should (see attached image. I need to look at the DFFS config to see if I can see anything that could explain it – can you attach or email me the “blob” exported the DFFS config tab “Export, import and restore”?

      Alexander

      Attachments:
    • #24675
      Joe Keyrouz
      Participant

      can you tell me how can i find it?

    • #24677
      Alexander Bautz
      Keymaster

      Go to your form, enter DFFS configuration by clicking the Enhanced with DFFS link below the form an then select the tab Export, import and restore > Export settings.

      Alexander

    • #24679
      Joe Keyrouz
      Participant

      I have attached the file.
      Thank you

      Attachments:
      1. dffs-export.txt
    • #24682
      Alexander Bautz
      Keymaster

      Thanks,
      Unfortunately there were nothing in this config that could explain it. Do you have any other third party code other than DFFS running in this form?

      You can try uninstalling DFFS in this form (the config will not be lost – it will pop back in when you reinstall DFFS) and let the user that experience problems access the form when it is not using DFFS to see if it is related.

      Alexander

    • #24684
      Joe Keyrouz
      Participant

      I have uninstalled DFFS on the new form, the users were able to acces the old form successfully.
      I reinstalled DFFS; then with a user having the rules problem i clicked on enhanced with DFFS and got the attached error. If he clicks on OK he accesses the DFFS config page

    • #24687
      Joe Keyrouz
      Participant

      Attached the rules screen; the product also appears as unlicensed

    • #24693
      Alexander Bautz
      Keymaster

      OK, that means the user cannot access the configuration list – it is located in “Site content” and is named “SPJS-DynamicFromsForSharePoint”. If the user can access it in the browser it might be that the user have limited rights and does not have the “Use Remote Interfaces – Use SOAP, Web DAV, the Client Object Model or SharePoint Designer interfaces to access the Web site.” permission.

      Alexander

    • #24705
      Joe Keyrouz
      Participant

      Hello,
      I am not finding that list (DFFS is working fine with my account)/ i can only find spjs document library

      • This reply was modified 1 year, 6 months ago by Joe Keyrouz.
    • #24708
      Alexander Bautz
      Keymaster

      The list might be hidden – you can unhide it from the Misc tab in DFFS config, or you can type the list name in the browser like this:

      /Lists/SPJSDynamicFormsForSharePoint/AllItems.aspx

      Alexander

    • #24710
      Joe Keyrouz
      Participant

      Thank you; i tried it with a test account and it is working; i am waiting for my colleagues who had the problem to confirm; I will contact you if the problem still exists. Thank you for your support and help

Viewing 22 reply threads
  • You must be logged in to reply to this topic.