Multiple email addresses include “\n”

Forums Cascading dropdowns Multiple email addresses include “\n”

  • This topic has 7 replies, 2 voices, and was last updated 1 year ago by MikeS.
Viewing 7 reply threads
  • Author
    Posts
    • #31403
      MikeS
      Participant

      Alexander,

      I would like to use cascading dropdowns as a multi-value people picker as I can apply filters, which is not possible with SharePoint OOTB multi-value people picker. The emails are auto filled in the second multi-line text box so that they can used in the TO: field in a DFFS email. However, a “\n” is being inserted between each email address and as a result the DFFS email is not being sent to the multiple email addresses collected with the cascading dropdown.

      Emails returned from cascading dropdown: john.doe@abc.com;\njane.doe@abc.com;\n

      Can the “\n” characters be removed somehow, perhaps with a rule governing another field?

      Thanks,
      Mike

    • #31420
      Alexander Bautz
      Keymaster

      Hi,
      You find information on how to change this delimiter here: https://spjsblog.com/dffs/dffs-plugins/spjs-cascading-dropdowns/#Change_multichoiceDelimiter

      Just change it to “;” and you should be good to go.

      Alexander

    • #31424
      MikeS
      Participant

      I am using DFFS 4.4.4.32. Since I do not see the “Change multichoice delimiter” in my Cascading dropdown options at the bottom of the screen was it added in a later version?

      Mike

    • #31426
      MikeS
      Participant

      I updated to the latest DFFS 4.4.5.5 and I still do not see the “Change multichoice delimiter” option.

      Mike

    • #31428
      Alexander Bautz
      Keymaster

      You don’t have that option in the Cascading dropdown tab in the DFFS config, only when you call the function manually form Custom JS: https://spjsblog.com/dffs/dffs-plugins/spjs-cascading-dropdowns/#Invoke_the_function_manually

      Alexander

    • #31430
      MikeS
      Participant

      Yes, I determined that and have configured my Custom JS. However, I’m unable to deactivate the Cascading dropdowns panel by deleting all entries as I get the message, “Error in “Cascading dropdowns” tab! The FieldInternalName “” is incorrect”

      Is there a way to remove that?

      Mike

    • #31432
      Alexander Bautz
      Keymaster

      You should just hit the “delete” link in the bottom right corner of the Cascading dropdown config.

      Alexander

    • #31434
      MikeS
      Participant

      Yep, my mistake. I’ve got the Custom JS configured and working great with the correct delimiter.

      Thanks for your help,
      Mike

Viewing 7 reply threads
  • You must be logged in to reply to this topic.