Issue with people picker field on save

Forums Dynamic Forms for SharePoint Issue with people picker field on save

Viewing 2 reply threads
  • Author
    Posts
    • #15308
      chgrnet
      Participant

      This issue started for me during one of your releases late last year. I have worked around it, but was wondering if there was some way you can fix it. Before the update, I had no issues with this.

      1. I click edit on a new or edit form. I have a people picker field that is required in DFFS and from the list.
      2. Person fills in the people picker field and resolves the name.
      3. Person clicks Save, but an error comes up on the people picker that says a value is required and will not save the form. There is a value in the field.

      What I am doing right now is removing the required rule in DFFS, but it would be nice if it worked as it did in the past, causing no issues. The error that is shown appears to be a DFFS based error, not a list based error.

    • #15359
      Alexander Bautz
      Keymaster

      I’m not able to recreate this issue. I have tested it in both Chrome and IE on SP 2010 and 2013.

      Could you give me some more details about the DFFS version, SP version and which browser you use?

      If you are able to open the form NOT in a dialog, you can try this in the Console (hit F12 > Console):

      spjs.utility.getFieldValue({"fin":"PutYourFieldInternalNameHere,"delimiter":",","key":"loginName"});

      Change “PutYourFieldInternalNameHere” with the name of your PeoplePicker.

      What was the output in the console?

      Alexander

      • #15370
        chgrnet
        Participant

        Do you think using content types would make a difference? I am using IE 11.0.38, latest version of DFFS (Jan. 12), SP 2010. I will work on the test above next.

      • #15372
        chgrnet
        Participant

        I’m not sure if I ran the code in the console correctly, I am going to get some help in a little while to make sure, but here is a screen shot from what I did by following your instructions above.

      • #15406
        chgrnet
        Participant

        I have installed the Jan. 12 version of DFFS. Attached is the screen shot with your code in F12 developer tools. Here are the scenarios:

        1. If I put a name in the field and resolve it, I get the error and am not able to move forward.

        2. If I put a name in the field and don’t resolve it, I don’t get the error and the form saves as expected.

        The required feature is only available on DFFS, not on the list.

        This list does not use content types, but I have 2 other lists that do use content types and work the same way.

    • #15389
      AdamP
      Participant

      Is this the same as the issue discussed here

      Christine – are you running IE11 32 bit or 64 bit???
      I think the conclusion we came to last time was that 64 bit IE11 was the likely reason;
      In the console run

      browseris.win32

      and

      browseris.win64bit

      You should get a true or false response for each…let’s see if it’s 64 bit

Viewing 2 reply threads
  • You must be logged in to reply to this topic.