Hidden Tabs

Forums Dynamic Forms for SharePoint Hidden Tabs

Viewing 8 reply threads
  • Author
    Posts
    • #32266
      Danielle Arcuri
      Participant

      Hello, I have an issue where hidden/visible tabs is not working. I am using SharePoint groups and have the visibility set on the Tab settings. It used to work and now it stopped work. I tried to create a rule on group membership and that is not doing the trick either. Any ideas?

    • #32269
      Alexander Bautz
      Keymaster

      Hi,
      This is usually caused by other rules interfering. Do you have any other rules showing of hiding the same tabs?

      PS: A rule will override the hidden settings in a tab.

      A little tip:
      Use the “Rule friendly name” field to give your rules a name so you (and others coming after you) can easily see what the rule is supposed to do. This name is also shown in the debug output. You should also give your tabs a “Tab unique ID” and use this name when you show or hide tabs – this way your rules will still work if you rearrange the tab order.

      Alexander

    • #32272
      Danielle Arcuri
      Participant

      My other rules don’t indicate hidden or visible tabs. These are the only two rules (screenshots attached). I don’t understand if I make the tabs only visible to certain groups in the TAB settings why do I need a rule? Plus it isn’t working. Does it have anything to do with reversing or disable reversing of rule?

      Attachments:
    • #32275
      Alexander Bautz
      Keymaster

      Hi,
      You should not have to use both rules and the group setting in the tabs. I’m not sure why the settings in the tab don’t work, but I’ll look into it and get back to you.

      I’m not 100% sure, but it might be that this is fixed in a later version (I have fixed some issues when using multiple triggers of the same kind).

      If you are able to update to the latest version to test it would be great.

      Alexander

    • #32281
      Alexander Bautz
      Keymaster

      I have done some tests with the version you use but cannot reproduce this behavior. Do you use any custom js or custom css that could interfere?

      Alexander

    • #32283
      Danielle Arcuri
      Participant

      I have updated to the newer version and I still have users unable to see the tab I want them to see. I deleted the rules and only have the setting on the Tabs. There is no custom JS or CSS that I am aware of to interfere. I tested this on a different list and it worked no problem…

    • #32285
      Alexander Bautz
      Keymaster

      It is unfortunately hard to tell without looking at it live. You can try deleting the config and recreating it (you can back it up first) – maybe there is something in the config that messes it up.

      If I could have a look at it – either by getting access or in screen sharing session I try my best to figure out what is going on.

      It is getting late here in Norway so it would have to be sometime later this weekend or next week.

      Send me an email if this is an option.

      Alexander

    • #32287
      Danielle Arcuri
      Participant

      Thank you Alexander. I think I discovered the issue. In my SP group I was using an outlook distribution list and I don’t think DFFS recognized the users. When I removed the distribution list and added the names in the SP group it worked.

    • #32289
      Alexander Bautz
      Keymaster

      I’m glad you figured it out. You are right, DFFS cannot identify individual users when a distribution list is added to a SP group. I have however added a new trigger for use with SharePoint Online / Azure AD in a later version of DFFS. You find it as “Azure Active Directory (Azure AD): Logged in user is member of group” in the trigger-dropdown when you configure a rule.

      Alexander

Viewing 8 reply threads
  • You must be logged in to reply to this topic.