Cross-browser compatibility

Forums Dynamic Forms for SharePoint Cross-browser compatibility

Viewing 8 reply threads
  • Author
    Posts
    • #30414
      DevAmb
      Participant

      Is DFFS compatible with Firefox?
      I’m having trouble opening pages that, for example in Chrome, are quick to open.

      I would appreciate help.

      Error loading: /SPJS/DFFS/js/DFFS_frontend_min.js

    • #30422
      Alexander Bautz
      Keymaster

      Firefox should work, but I suggest you update your DFFS Installer to V2 and reinstall DFFS in your lists because the V1 installer / loader sometimes fails to load the files.

      You find the installation manual here: https://spjsblog.com/dffs/dffs-installation-manual/#InstallDFFS

      Alexander

    • #30618
      DevAmb
      Participant

      Hi.

      I installed v2 and in Firefox I have these errors. Can you help, please. Thanks.

      Attachments:
    • #30624
      DevAmb
      Participant

      Hi.

      I have the following:

      jQuery v1.12.4
      SPJS-utility v1.348

    • #30629
      Alexander Bautz
      Keymaster

      I’m unfortunately not able to recreate this using the latest version of Firefox. Is this happening in all your forms, or only this DispForm?

      Alexander

    • #30631
      DevAmb
      Participant

      Hi.

      It happens in DispForm and EditForm, in Firefox and Edge.

      When the page loads after logging in to sharepoint, it gives sp.js loading errors, but I’m calling the functions with the “ExecuteOrDelayUntilScriptLoaded” statement.
      I can’t understand why Chrome loads js files well and other browsers don’t.
      My Firefox version is 76.0.1.
      My Chrome version is 83.0.4103.97.
      My Microsoft Edge version is 42.17134.1038.0.

      I load “fabricmenuicons” and they come with jquery.min.js (jQuery v1.10.2), then later i load jquery from dffs.

      Is it the order of the jquery declaration or another file perhaps?

    • #30633
      Alexander Bautz
      Keymaster

      What are you loading using ExecuteOrDelayUntilScriptLoaded? – I thought this was a clean install of DFFS?

      Alexander

    • #30635
      DevAmb
      Participant

      Hi,

      I don’t know if I understand what you’re asking. I just indicated that I use ExecuteOrDelayUntilScriptLoaded to load functions, because in Firefox there is an error loading sj.js.
      They are functions that check permissions and groups associated with the logged in user or functions that write simple html.

      I installed DFFS v2 and started giving errors saying that it was necessary to have version +1.26 of SPJS-utility.js. The error has no reason to be because my version is 1.348. I reversed and stopped giving this error warning.

      Attachments:
    • #30646
      Alexander Bautz
      Keymaster

      Not sure, but I suspect you might have an older version of DFFS (or only SPJS-Utility loaded in this form from a previous customization).

      Please try using the DFFS installer and then hit the red “Remove ALL Content Editor Web Parts from this form” button to clear all custom Content Editor Web Parts from this form.

      Alexander

Viewing 8 reply threads
  • You must be logged in to reply to this topic.