Chart error when "Treat ZERO values as null" is enabled

Forums SPJS Charts for SharePoint Chart error when "Treat ZERO values as null" is enabled

Viewing 5 reply threads
  • Author
    Posts
    • #9352
      Jhap
      Participant

      Sir Alexander,

      Good day!

      I noticed these issue long ago that when only single data is appeared in the chart and “Treat ZERO values as null” is enabled (Figure 3), the chart is getting error as shown in Figure 1 in the attached image.

      But when “Treat ZERO values as null” is disabled then the chart is OK as shown in Figure 2 even only single data appeared in the chart.

      My setting is shown in Figure 4 in the attached image.

      There is no error shown in debugging if F12 is press. Any thought of this problem please.

      Thank you very much.

    • #9386
      Alexander Bautz
      Keymaster

      Hi,
      This setting is intended used in a line chart with “missing” data points to create gaps in the line instead of the line dropping to 0 for the “missing” data point.

      Did you see a use for this setting in your column chart, or was this only an observation?

      Alexander

    • #9400
      Jhap
      Participant

      Thank you for the reply Sir. Yes, I am getting this error in column chart.

      • This reply was modified 4 years, 10 months ago by Jhap.
    • #9410
      Alexander Bautz
      Keymaster

      I see. I don’t have any other solution that to not use it I’m afraid. I will however keep this in mind when I finish developing the new version to see if I can avoid this error.

      Alexander

    • #9529
      Jhap
      Participant

      I also noticed that when “Use custom CAML (overrides selected view)” is enabled and the list is empty it is getting error as shown in the attached image.

      Regards..

    • #9561
      Alexander Bautz
      Keymaster

      Thanks for the feedback. I’ll keep this in mind when I resume the work on the next release of this solution.

      Alexander

Viewing 5 reply threads
  • You must be logged in to reply to this topic.