Cascading Multi Field not displaying after edit

Forums Cascading dropdowns Cascading Multi Field not displaying after edit

Viewing 14 reply threads
  • Author
    Posts
    • #26616
      Anne Maki
      Participant

      Hi,

      In one of the forms I created, I’m using cascading dropdowns with the multi option. It works really well until the user goes back in after saving the values. One of the dropdown fields does not display the values that were saved – it shows blank (see image). When I look at the list, the values are there.

      What could be happening?

      Thanks,
      Anne

      Attachments:
    • #26622
      Alexander Bautz
      Keymaster

      Hi,
      I’m not 100% sure, but please verify that the multiline text field OversightCountry is plain text.

      Alexander

    • #26627
      Anne Maki
      Participant

      I checked and it is set up as plain text.

      What’s interesting is that I have another cascading dropdown set up exactly the same way but different content and that one works.

      Anne

    • #26629
      Alexander Bautz
      Keymaster

      If you look at the list item in DispForm – how does the selected values show there?

      Could you post the configuration for your cascading dropdown here so I can look at it?

      Alexander

    • #26651
      Anne Maki
      Participant

      The display form shows the information. Attached are the snippet from the display form and the Cascading Configuration

      • This reply was modified 1 year, 1 month ago by Alexander Bautz. Reason: Removed URL from image
    • #26657
      Alexander Bautz
      Keymaster

      Thanks, I forgot to ask which version of SPJS-casc you are running?

      Alexander

    • #26661
      Anne Maki
      Participant

      Cascading dropdowns v3.7.26 :: Plugin documentation

      Is this what you’re looking for?

      Anne

    • #26663
      Alexander Bautz
      Keymaster

      Yes, this was it. I’ll have to do some testing, but I have released a new version of this plugin on July 21 that you could test. I haven’t fixed this directly, but I have done some small changes regarding the :multi functionality so I might have *accidentally* fixed it.

      If you are able to update to the latest version of the DFFS package and test I appreciate you feedback.

      Best regards,
      Alexander

    • #26710
      Alexander Bautz
      Keymaster

      Hi,
      I ran a test based on your screenshots and it works as it should in my testsite. Can you confirm that you have used the same setup for the cascading dropdown for both NewForm and EditForm?

      Alexander

    • #30041
      Jose Ramirez
      Participant

      Hi, I am having the same issue, the new form dropdowns works fine and the Disp Form shows the options chosen, when using the EditForm it only populates the first dropdown, all others blank.

      Thanks

    • #30060
      Alexander Bautz
      Keymaster

      I didn’t get any further replies on this thread so I never got this issue sorted out.

      To help you I need some screenshots and any information to let me replicate the issue. Please post your current configuration and if you are able, please set up a test list to ensure you can replicate the behavior in a separate list.

      Alexander

    • #30064
      Jose Ramirez
      Participant

      I recreated in a separate list and it works, here are some screen-prints. I also exported the newform configuration into the editform and the issue persist.

    • #30124
      Alexander Bautz
      Keymaster

      I see that you use an older version of the SPJS-Casc plugin (July 21, 2019). I don’t know what the cause of your problem is so I cannot tell if it has been fixed in a later version, but if you are able to update to the latest version and test it it would be great.

      You don’t have to update the entire DFFS package, just download it and replace only the SPJS-Casc.js file in the /SPJS/DFFS/plugins folder.

      In any case I would appreciate a screenshot of the item you are trying to select in the lookup list so I can see how the values for State, City and Floor are stored in this list.

      Alexander

    • #30134
      Jose Ramirez
      Participant

      Updated to the newer version, issue remains. I entered test values in the lookup list and it doesn’t have the error. see screenshots

    • #30148
      Alexander Bautz
      Keymaster

      OK, if the test data works it must be a problem with the production data – can you show me one of the records that fail? – does it use any special characters?

      Alexander

Viewing 14 reply threads
  • You must be logged in to reply to this topic.