Cascade Dropdowns not usabale

Forums Cascading dropdowns Cascade Dropdowns not usabale

Viewing 5 reply threads
  • Author
    Posts
    • #24829
      Eric Dickerson
      Participant

      I have a DFFS form that is telling me the loader file for Cascade dropdowns is not loading… but if I look at the loader it is there… further testing I added resourse managment and it works now… but still no Cascades attached is the Loader file and a screenshot the plugin error I get along with DFFS version info

      Ok… html files not allowed… here is the code from the top part of the file:

      
      
      <!-- DFFS CEWP Loader - August 17, 2017 -->
      <script type="text/javascript">
      /* 
      This variable tells the script where the SPJS document library is located
      current = the files are in the current site
      parent = the files are in the parent of current site
      root = the files are in the site collection root
      */
      var dffs_folder_location = "current";
      
      /*
      This variable tells DFFS which plugins to load
      Avaliable plugins:
          SPJS-casc = Cascading dropdowns
          SPJS-ac = Autocomplete
          SPJS-lookup = Lookup
          SPJS-vLookup = vLookup
          SPJS-rm = Resource management
      */
      var spjs_plugins = [
          "SPJS-casc",
          "SPJS-ac",
          "SPJS-lookup",
          "SPJS-rm",
          "SPJS-vLookup" // Required
      ];
      
      /* If you have a corporate or site collection license (NOT SITE LICENSE) you can add it to this variable to have it automatically loaded in all sites using this instanse of the DFFS_loader */
      var dffs_master_licensecode = "";
      
      /******************************/
      /* No changes below this line */
      /******************************/
      • This topic was modified 1 year, 1 month ago by Eric Dickerson. Reason: added code since html files not allowed
    • #24835
      Alexander Bautz
      Keymaster

      Sounds strange – try bringing up the developer tools and look at the Network tab and see if the spjs-casc.js file is loaded, and if it shows any errors.

      Alexander

    • #24846
      Eric Dickerson
      Participant

      File does not load but it give the error below (also attached as screen shot):

      
      
      Uncaught TypeError: Cannot read property 'SPCascadeDropdowns' of undefined
          at HTMLDocument.eval (eval at <anonymous> (jquery.js:2), <anonymous>:169:17)
          at i (jquery.js:2)
          at Object.add [as done] (jquery.js:2)
          at n.fn.init.n.fn.ready (jquery.js:2)
          at eval (eval at <anonymous> (DFFS_frontend_min.js:9), <anonymous>:1:142709)
          at arguments.(/sites/portal/intran…/anonymous function) (https://static.sharepointonline.com/bld/_layouts/15/16.0.8803.1223/init.js:1:100741)
      (anonymous)	@	VM14653:169
      i	@	jquery.js:2
      add	@	jquery.js:2
      n.fn.ready	@	jquery.js:2
      (anonymous)	@	VM14644:1
      arguments.(anonymous function)	@	init.js:1
      setTimeout (async)		
      window.setTimeout	@	init.js:1
      loadConfig	@	VM14644:1
      (anonymous)	@	VM14644:1
      ExecuteOrDelayUntilEventNotified	@	init.js:1
      ExecuteOrDelayUntilScriptLoaded	@	init.js:1
      init	@	VM14644:1
      (anonymous)	@	VM14644:1
      (anonymous)	@	/SPJS/DFFS/js/DFFS_frontend.min.js:9
    • #24850
      Alexander Bautz
      Keymaster

      SPCascadeDropdowns is not referring to my cascading dropwdown, but to SPServices. Please ensure you load this script before you try to access it in Custom JS.

      Alexander

    • #24852
      Eric Dickerson
      Participant

      Sorry… that was my confusion… this form used to use SPServices Cascade Dropdowns… we would like to switch it to DFFS Cascading dropdowns… so that error is not relevant to this discussion. Fact remains the the loader calls on spjs_casc file and the file is in the plug-in directory, but it does not load. I can give you access if that would help.

    • #24854
      Alexander Bautz
      Keymaster

      I see. Please note that the SPServices casc solution uses proper lookup columns, while the spjs-casc uses plain text fields. This means you cannot just switch from SPServices to SPJS-Casc without changing to plain text columns.

      If you send me login details I’ll look at it later tonight.

      Alexander

Viewing 5 reply threads
  • You must be logged in to reply to this topic.