Autocoplete problems

Forums Dynamic Forms for SharePoint Autocoplete problems

Tagged: ,

This topic contains 3 replies, has 2 voices, and was last updated by  Alexander Bautz 1 year, 2 months ago.

  • Author
  • #20674

    Phil Grant

    Browser IE11
    DFFS version
    Sharepoint 2010

    I just thought I’d try the autocomplete feature but not working as I’d hoped.
    1. I setup a list with one column as a single line text, created a few records.
    2. followed the instructions to link the list.{
     "applyTo": "Diagnostic_x0020_Address",
     "helpText": "Start typing the Diagnostic Address",
     "loadText": "",
     "listGuid": "{8DA6252C-231E-476C-B423-A605F0464E3E}",
     "listBaseUrl": "Site address confirmed in F12 console",
     "showField": "Column1",
     "searchFields": [],
     "filterCAML": "",
     "useREST": false,
     "filterREST": "",
     "optionDetailFields": [],
     "optionDetailPrefix": [],
     "enforceUniqueValues": true,
     "rowLimit": 15,
     "listOptionsOnFocus": false,
     "minLengthBeforeSearch": 3,
     "reValidateOnLoad": false,
     "allowAddNew": false,
     "isLookupInSelf": false,
     "addNewAdditionalFields": [],
     "multiselect": false,
     "multiselectSeparator": "; ",
     "orderBy": [],
     "setFields": [],
     "debug": true

    Debug in console gives me this

    • This topic was modified 1 year, 2 months ago by  Phil Grant.
    • This topic was modified 1 year, 2 months ago by  Phil Grant.
  • #20691

    Alexander Bautz

    Try setting the “searchFields” to the same value as the “showField”. Also ensure that “Column1” is the correct fieldinternalname of the field in your target list.


  • #20719

    Phil Grant

    I found the “searchFields” info on another post but it didn’t make any difference.
    I’m sure that the “Column1” is the column title, but I tried again with a new list with different names but I still get the error.


  • #20738

    Alexander Bautz

    What happens if you use the “Title” field instead of the “Column1 field? Could you email me some screenshots of the config and the datasource for your autocomplete (the list with the field “Column1”.


You must be logged in to reply to this topic.