Allo custom value in autocomplete text box

Forums Autocomplete Allo custom value in autocomplete text box

This topic contains 5 replies, has 2 voices, and was last updated by  Dirk Loehn 3 years, 5 months ago.

  • Author
  • #10248

    Dirk Loehn

    Hello Alexander,

    is there any way to allow additional custom values in the autocomplete text box. Right now the autocomplete enforces the selection of an existing entry. In our Case we pull a list of suppliers for the autocomplete field, but would like to allow the user to type in a custom supplier name. If you do so now and leave the autocomplete field, the entry is deleted.

    Is it possible to add such an Option, or is there an easy Workaround?

    Thanks a lot,


  • #10259

    Alexander Bautz

    Sorry, but this is currently not possible. I have just answered the same question here

    I’ll try to get this added, but I’m a bit busy right now.


  • #10326

    Alexander Bautz
  • #10331

    Dirk Loehn

    Works great with adding a new entry, thanks a lot!!!

    One problem still is with localization.
    E.g. if we set translated attributes like
    if (lcid == 1031){
    // GERMAN = {“noItems”:”Keinen passenden Eintrag gefunden”, “noValidItems”:”Keinen gültigen Eintrag gefunden”,
    “invalid”:”Auswahl ist ungültig”,
    “moreItemsLabel”:”Es werden die ersten {0} Einträge angezeigt”,
    “moreItemsMouseover”:”Geben Sie weitere Zeichen ein, um die Auswahl einzugrenzen”,
    “searching”:”Suche nach: ”

    then entering an entry with no Match will result in deleting the entry.
    We have used the setting:
    “allowAddNew”:true, // New in v1.4
    “isLookupInSelf”:false, // New in v1.4

    Apart form this its working great!!!

  • #10333

    Alexander Bautz

    You must update the “” object for 1031 to include the new key/value pair:

    "addNewItem":"Add {0} to the list?"

    You find this in the description in the original article here (under “Override the labels and text”):

    Does this help?


  • #10335

    Dirk Loehn


    works like a charm – Thanks

You must be logged in to reply to this topic.