Bug/issue with rule in 4.253, worked in 4.250

Forums Dynamic Forms for SharePoint Bug/issue with rule in 4.253, worked in 4.250

This topic contains 8 replies, has 2 voices, and was last updated by  Alexander Bautz 2 years, 6 months ago.

  • Author
    Posts
  • #7070

    Erik Thomte
    Participant

    Plattform: O365
    Browser: IE 11 and Chrome (newest)

    Upgraded 4.250 to 4.253, and newest sp-utility.
    After the upgrade I got problems with displayform with a special rule (newform and edit hadn’t this rule).

    Rule Trigger: “If logged in user is NOT in group with name or ID”
    This Value : “GroupA|GroupB”

    Error in Chrome console:
    “Uncaught TypeError: Cannot use ‘in’ operator to search for ‘164’ in 27;#Dummy Name,#i:0#.f|membership|dummy@dummy.onmicrosoft.com,#dummy@dummy.onmicrosoft.com,#dummy@dummy.onmicrosoft.com,#dummy

    query-lastest.min.js:2 rquery-lastest.min.js:2 m.extend.eachVM11730:1 (anonymous function)query-lastest.min.js:2 m.extend.eachVM11730:1 spjs.dffs.getCurrentItemSP13VM11730:1 spjs.dffs.initVM11730:1 (anonymous function)

    DFFS 2.53 (also tried 54/55 – same error ) overlay timed out on the displayform, and no link to DFFS config, a regular SP list form was displayed.

    Rolled back to v 4.250 of DFFS_backend_min.js and DFFS_backend_min.js, and the display form work fine again.

  • #7071

    Erik Thomte
    Participant

    Additional info:

    After reverting back to 4.250 I also deleted the rule and set up a new one (4.254 or 4.255 complained at the top of the browser about errors in config).
    Set up 4.253/54/55 again, but lo nuck. Rolled back to 4.250 once more, evrything worked fine again.

    FYI:
    The rule was set up to hide 3 fields, and run a JS function.

    But I assume the issue is with “Cannot use ‘in’ operator to search for” person in group name error msg.

  • #7072

    Alexander Bautz
    Keymaster

    Hi,
    I cannot recreate this error. Could you test the unminified version attached and see if you can locate the line number where the error originates from?

    Best regards,
    Alexander

    Attachments:
    1. DFFS_Frontend.zip
  • #7074

    Erik Thomte
    Participant

    I disabled the rule first in DFFS(check box)

    Then I added the content of the txt straight into min file for easy debug

    Still same error (even with a disabled rule).

    Se attached picture for line number errors.

    I will test with removing the rule alltogheter, if that doesn’t help I will delete the entire config doc

  • #7076

    Erik Thomte
    Participant

    Rolled back to 4.250 deleted the rule, saved the config. Verified that the config was updated, no rules for disp form anymore.

    Back in with unminified 4.253, same error.

    Deleted the DFFS config doc for disp form in SPJSDynamicFormsForSharePoint list.
    Same error when opening a list item, and the DFFS config link didn’t show..

    Checked that the content editor contained the same path to DFFS_frontend_CEWP.html for display form and new form /edit , everything checked out.

  • #7077

    Alexander Bautz
    Keymaster

    I was able to recreate the error and will fix it shortly.

    Alexander

  • #7079

    Alexander Bautz
    Keymaster

    I have released v4.255 of DFFS frontend. Could you test to see if the error is fixed?

    Alexander

  • #7085

    Erik Thomte
    Participant

    Tested with v4.255 of DFFS frontend, v4.254 of DFFS backend, and spjs-utility 1.205.
    Checked with both IE and Chrome.

    The error is fixed, everything works fine.

    Thanks for a quick fix Alexander !

  • #7086

    Alexander Bautz
    Keymaster

    Thank you for the feedback.

    Alexander

You must be logged in to reply to this topic.