Show and Hide Fields

Forums Dynamic Forms for SharePoint Show and Hide Fields

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  Alexander Bautz 7 months, 2 weeks ago.

  • Author
    Posts
  • #20119

    Caron Shimo
    Participant

    I have recently upgraded and getting a feel for the new version. In my current forms I have the ability to show and hide fields when they are selected which is working. What doesn’t work is if I am in a form and I select one thing and then change the selection to something else, it doesn’t automatically hide the fields that are not needed. it shows both sets of fields for the first selected option then fields for the option it is changed to also.

    When Add/Modify/Remove values is selected in Type of Request – Agent Data Groups the following field visible and required
    ◦Add/Modify/Remove Values from which ADG
    ◦New/Modify/Remove AD Value
    ◦MU Number and Name

    When New ADG is selected in Type of Request – Agent Data Groups the following field visible and required
    ◦Name of New ADG
    ◦New/Modify/Remove AD Value
    ◦MU Number and Name
    ◦Business Need for New ADG

    If I toggle between the 2 selected values in the old version it would hide the fields not listed as visible and required.. Can someone help me on how this version would allow me to do the same. Do I need to write the rules differently? The user would have to refresh the page to get the correct field if a mistake or another selection was made within the same field

  • #20172

    Alexander Bautz
    Keymaster

    If you could you add some screenshots of your rules so I can see what you have set up I’ll help you sort it out.

    Alexander

  • #20177

    Caron Shimo
    Participant

    Attached rules

  • #20184

    Alexander Bautz
    Keymaster

    Thanks, but could you also include the “trigger” section in the rule (the top part)?

    Alexander

  • #20186

    Caron Shimo
    Participant

    Sorry added

  • #20191

    Alexander Bautz
    Keymaster

    Try setting the “Validate on” to both “Form load and field change” to also trigger when the form loads (important in EditForm at least).

    Then try removing the selection in the “No reversing of this rule” to ensure it reverses the visible / hidden and optional / required settings when the rule don’t match.

    It that doesn’t work, I’ll take another look at it.

    Alexander

You must be logged in to reply to this topic.