No "Enhanced with DFFS" link on form

Forums Dynamic Forms for SharePoint No "Enhanced with DFFS" link on form

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  Alexander Bautz 3 years, 3 months ago.

  • Author
    Posts
  • #7635

    scottk
    Participant

    I have got this solution working (same was as described below) on 3 test servers (2-2013 & 1-2010 in different domains) and cannot get it to work on the production 2010 server.

    -all backend scripts are in a /scriptlibrary/dffs folder at the root (it is an SP library)
    -the DFFSBackend page is in the root site /sitepages library
    -all frontend scripts are in the specific department site in the /siteassets/scripts

    The backend page shows the expected dialog “You must have the URL parameters…”

    I have added an “alert” command to the first line of spjs-utility, spjs-casc-min, DFFS_Frontend_min to show that the files are called correctly – and I get prompt from all 3 of these when loading the form.

    The form loads with the “overlay” and when it disappears – voila – no “Enhanced with DFFS” link.

    Any other troubleshooting tips?

  • #7636

    Alexander Bautz
    Keymaster

    Hi,
    It’s hard to tell what it could be, but ensure you have the DFFS_frontend web part below the form web part.

    Was this the issue? – if not, do you see any errors in the developer console? (hit F12 > Console)

    Alexander

  • #7637

    scottk
    Participant

    Yes – the DFFS Frontend CEWP is below the form, only the Overlay is above.

    2 warnings that I’m not familiar with:
    1) jQuery_1.11.3_min.js: Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/
    2) MicrosoftAjax.debug.js: Use of Mutation Events is deprecated. Use MutationObserver instead.

  • #7638

    Alexander Bautz
    Keymaster

    Could you have hidden the “Enhanced with DFFS” link in the configuration for this form (in the Misc tab) – if you have any config already saved.

    What type of list is it you are trying to use DFFS with?

    Could you try setting DFFS up with another list to test if it is an issue for this form only?

    Alexander

  • #7652

    scottk
    Participant

    That was the exact problem – creating a new custom list allowed the DFFS tool to work just fine.

    The original list had some custom columns from a Codeplex add-on.

    thank you…

  • #7669

    scottk
    Participant

    The problem is that the original list was created with the “SharePoint List Association Manager” (http://slam.codeplex.com/). This tool apparently creates a different list column structure in the form, so the DFFS tool does not recognize the columns and does not function.

  • #7752

    scottk
    Participant

    Further along on this project – I found another similar issue – but not related to SLAM – per above.

    ISSUE:
    I have created an additional “Edit” form from SharePoint Designer
    – testedit.aspx for example

    When adding the DFFS Overlay & DFFS Frontend CEWPs to the page, the Overlay works, but the “Enhanced with DFFS” link never shows up.

    I can add it to the default forms: dispform.aspx, editform.aspx, newform.aspx; but cannot and “Enhanced with DFFS” shows up fine.

    Does DFFS work on any additional forms? Or is there a nuance to make it work on additional forms created from SharePoint Designer?

  • #7753

    Alexander Bautz
    Keymaster

    Hi,
    Unfortunately DFFS does only support unmodified forms (no SPD customization).

    Alexander

You must be logged in to reply to this topic.