PreSave running on load on new form

Forums Dynamic Forms for SharePoint PreSave running on load on new form

This topic contains 5 replies, has 2 voices, and was last updated by  chgrnet 3 weeks, 4 days ago.

  • Author
    Posts
  • #26337

    chgrnet
    Participant

    I am testing your latest version, thank you for all the updates! It appears to be working well, but I am seeing a rule I have set up for PreSave running on load on a new form. Maybe I have it setup incorrectly, but it works as expected in the January 2019 version.

  • #26339

    chgrnet
    Participant

    One other note about this, this is an old list and even though the field is not set as required, it seems to be required somehow, and I’m not sure why (not your problem).

    I also set the PreSave rule with linked rules, but it seems it is running regardless of the linked rules in latest version.

    • This reply was modified 3 weeks, 5 days ago by  chgrnet.
  • #26342

    Alexander Bautz
    Keymaster

    Thank you for the feedback – I have confirmed that the “The form is saved” trigger will be triggered on load also. I’ll fix this and release a new version as soon as possible.

    The required field is most likely set as required in the list settings or in the content type (if you use content types in the form).

    Sorry for the inconvenience,
    Alexander

    • #26352

      chgrnet
      Participant

      No problem, thank you! I have looked everywhere for where it is required and I cannot find it, it must be a glitch because my list is so old, but thank you!

  • #26358

    Alexander Bautz
    Keymaster

    If it is marked as required when you look at the Fields tab in DFFS and you don’t see it as required in the list settings AND you don’t use different content types – it might be a bug you can fix like this:

    Go into list settings > Advanced settings and click “Allow management of content types”. Then click to edit the default content type (most likely Item), and see if it is marked as required there. If it is, set it as optional, save and then disable content types by unchecking “Allow management of content types” again.

    Alexander

    • #26396

      chgrnet
      Participant

      Yes, good suggestion. I am using content types at the site level so I’m not able to turn them off then back on. I have gone through each one to see where they are required and none are required. In addition, the field does not show required when I click the Save button before filling out the value, it only shows when I click Save to complete the task and all other required fields have a value. It almost looks like there is validation on it, but I have looked and cannot find it. I cannot find a custom JS rule, or a regular rule with any rules. It is very strange.

You must be logged in to reply to this topic.