2019-1-12 to v4.4.4.5 (2019-8-12)

Forums Dynamic Forms for SharePoint 2019-1-12 to v4.4.4.5 (2019-8-12)

This topic contains 3 replies, has 2 voices, and was last updated by  Alexander Bautz 2 months, 3 weeks ago.

  • Author
    Posts
  • #26637

    chgrnet
    Participant

    The last version I have been able to work on most of my forms is from 2019-1-12. I am testing v4.4.4.5 now and for some it works, but I have a couple that don’t seem to be working as expected.

    They are not producing any errors, they just won’t Save and make it look like there is a hidden required field, but I’m not able to find what is missing.

    Something else that is strange is I have the feature turned on that is supposed to show the message at the top of what the required fields are, but for these that message does not show, even if I click Save when all required fields have no value. On the same form, different content type, the the required field message does show at the top, and it saves. I’m not sure where to look to fix the issue since there are no errors. I do have a tab with all the fields visible so it would show if something was required, but nothing shows up.

    Any ideas on how I can test this? I even turned off all required rules, and nothing happens when I click save.

    • This topic was modified 2 months, 4 weeks ago by  chgrnet.
  • #26649

    Alexander Bautz
    Keymaster

    I haven’t had any other reports of similar behavior so I don’t really know what could cause it. Did you try hitting F12 to bring up the developer console and then look at the Console tab when trying to save the form?

    Please post any error messages here.

    Alexander

    • #26680

      chgrnet
      Participant

      There were no errors, but I found 2 rules that were basically reversing themselves without the “no reverse” checkbox clicked. Once I fixed them, everything started working again, so issue resolved!

  • #26689

    Alexander Bautz
    Keymaster

    Thanks for the feedback – I’m very happy to hear that you were able to fix it.

    Alexander

You must be logged in to reply to this topic.