"This Took Forever" – DispForm and EditForm

Forums Dynamic Forms for SharePoint "This Took Forever" – DispForm and EditForm

Viewing 8 reply threads
  • Author
    Posts
    • #7025
      DCH
      Participant

      Alexander,

      Using the new v4.250/251 version I keep getting the “This Took Forever” message for my DispForm and EditForm. The NewForm works just fine. I searched the installation manual for any setup changes but I didn’t see anything. I didn’t change anything except copied the updated scripts to an existing SP2010 list that used the previous DFFS version v4.2.

      Thanks!

    • #7027
      Lana
      Participant

      I am having the same issue. And the link to the backend for editing is no longer on the form once it is opened. New Form is fine.

    • #7028
      Alexander Bautz
      Keymaster

      I’m currently working to resolve these issues, but I have not been able to recreate the errors locally.

      It would help if you could test this BETA, and the updated spjs-utility.js

      Open the developer console (hit F12 > Console) and click on any error messages and posti the line where the error occurs here.

      Also post the SharePoint version and which browser you use.

      Alexander

    • #7030
      DCH
      Participant

      Using those two files I was able to see the tabs on both the DispForm and EditForm, and I was able to access the backend configuration page, but I also got this alert on my page:

      The query cannot be completed because the number of lookup columns it contains exceeds the lookup column threshold enforced by the administrator. Operations that exceed the list view threshold are allowed in the following time window defined by the administrator: Daily, from 8:00:00 PM to 12:00:00 AM .

      • This reply was modified 5 years, 1 month ago by DCH.
    • #7032
      Alexander Bautz
      Keymaster

      Thank you for the feedback. Can you tell me how many fields of the following types you have in your form:

      1. People pickers
      2. Taxonomy fields / managed metadata

      Any other “complex” fields?

      Alexander

    • #7042
      Lana
      Participant

      Hi,
      I am working in SharePoint 2010, IE8 browser. I am using a very simple list. 8 columns, with 2 of those as lookups to other lists. This is a Test list for me as I am trying to understand the vLookup feature. I have yet to get it to work.

      I switched back from the 4.251 to the 4.250 and am still receiving the attached error. I am able to access the backend DFFS in 4.250….

      Thanks!
      Lana

      Attachments:
      1. Doc1.docx
    • #7049
      Alexander Bautz
      Keymaster

      I have done some work on the v4.25x version this weekend, and will be posting an updated version later today. I have removed a few bugs so I hope it will perform as expected.

      Alexander

    • #7054
      Alexander Bautz
      Keymaster

      Please test v4.253 and report any issues. I have not been able to recreate the error reported here, but hope I have been able to fix it anyways.

      Se complete change log here: https://spjsblog.com/dffs/dffs-change-log/

      Thank you for your patience,

      Alexander

    • #7114
      DCH
      Participant

      Yes, the new updates fixed the issue, thank you!

Viewing 8 reply threads
  • You must be logged in to reply to this topic.