DFFS Working for Certain Users Only

Forums Dynamic Forms for SharePoint DFFS Working for Certain Users Only

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Josef Wainz 1 week, 4 days ago.

  • Author
    Posts
  • #24182

    Josef Wainz
    Participant

    Hi,

    DFFS is only working for the account used to install it. All other users experience standard SharePoint. For example, I’ve a list with tabs configured. The spinning logo followed by the tabbed view appears when running under the install account. For everyone else, no spinning logo, just standard SharePoint.

    What did I miss during the install? What security change do I need to make?

    SharePoint Online environment.

    Version information
    DFFS frontend:
    4.4.3.48
    DFFS frontend CSS:
    4.44 /
    Autocomplete:
    1.6.22
    Cascading dropdowns:
    3.7.22
    jQuery:
    1.12.4
    Lookup:
    1.1.11
    Resource management:
    not loaded
    SPJS-Utility:
    1.324
    vLookup:
    2.2.123

  • #24190

    Keith Hudson
    Participant

    Josef,

    This sounds like a permissions issue. If you have Check In/Check Out turned on in your SPJS library and did NOT check in the DFFS files in your SPJS library, your users won’t be able to read them, hence they will get the native SharePoint form.

    It that is not the issue, check user permissions in the permission settings for the SPJS library using the “Check Permissions” icon in the ribbon. Also, make sure that permissions have not become fragmented in your library. Look for the yellow information bar on the permissions settings page for the library (or the site, if your SPJS library inherits its permissions from the site itself) and if it says “Some content has different permissions: click here” follow that link to find fractured permissions and re-inherit up to the SPJS library level.

    Good luck tracking it down!

  • #24208

    Josef Wainz
    Participant

    All the SPJS files were checked out. For some reason Title was a required field. I modified the Document Content Type at the Doc Lib level and made it Optional, then checked all the files in.

    Tabs are working now for everyone. Thanks.

You must be logged in to reply to this topic.