One or more field types are not installed properly

Forums Autocomplete One or more field types are not installed properly

This topic contains 2 replies, has 2 voices, and was last updated by  Alexander Bautz 1 week, 4 days ago.

  • Author
    Posts
  • #20444

    Melissa Hamilton
    Participant

    I am trying out the autocommplete plugin for DFFS. I have added a plain text field to my list called “RelatedPR” and am trying to lookup to the ID field. Here is my code block:

    /*autocomplete for RelatedPR field*/
    spjs.ac.textField({
    “applyTo”: “RelatedPR”,
    “helpText”: “Enter ID”,
    “loadText”: “Loading….”,
    “listGuid”: “76341ab8-8080-4475-b02d-4838c733dae5”,
    “listBaseUrl”: “”,
    “showField”: “ID”,
    “searchFields”: [],
    “filterCAML”: “”,
    “useREST”: false,
    “preloadData”:false,
    “filterREST”: “”,
    “optionDetailFields”: [],
    “optionDetailPrefix”: [],
    “enforceUniqueValues”: true,
    “rowLimit”: 15,
    “listOptionsOnFocus”: false,
    “minLengthBeforeSearch”: 3,
    “reValidateOnLoad”: false,
    “allowAddNew”: false,
    “isLookupInSelf”: true,
    “addNewAdditionalFields”: [],
    “multiselect”: false,
    “multiselectSeparator”: “; “,
    “orderBy”: [],
    “setFields”: [],
    “debug”: false
    });

    I keep getting this error:
    soap:ServerException of type ‘Microsoft.SharePoint.SoapServer.SoapServerException’ was thrown.One or more field types are not installed properly. Go to the list settings page to delete these fields.0x81020014

    I am sure its a minor tweak – any help you can provide would be appreciated. Thanks!

  • #20459

    Alexander Bautz
    Keymaster

    I cannot see anything obvious here – which version of SPJS-AC are you using?

    Alexander

  • #20521

    Alexander Bautz
    Keymaster

    Status update:
    This issue was sorted by specifying “searchFields”: [“ID”]. The issue where a blank “searchFields” causes this error has been fixed in v1.6.18, and this version will automatically set the “searchFields” the same as “showField” if left blank.

    Alexander

You must be logged in to reply to this topic.