On load, EditForm.aspx fields are not following rules

Forums Dynamic Forms for SharePoint On load, EditForm.aspx fields are not following rules

This topic contains 7 replies, has 2 voices, and was last updated by  Alexander Bautz 1 week, 4 days ago.

  • Author
    Posts
  • #18480

    chgrnet
    Participant

    Version:v4.4.3.10|CSS version: 4.37 / 4.37|spjs-utility version: 1.309
    Browser:

    I have rules set to show/require certain fields for new and edit form. It works perfectly for new but not on edit. If I select the item on edit, it works. On load, some load, some don’t, it seems random. Is this a known issue resolved by the latest version? I ran the debug and the correct rule is triggering, incorrect are not.

  • #18534

    Alexander Bautz
    Keymaster

    Hi,
    Sorry for the delay. Could it be that you have other rules that interfere with the rule in question? – try looking trough the rules and identify the ones targeting the same field and activate debug on those to see what is triggering.

    Alexnader

    • #18576

      chgrnet
      Participant

      I wish this was the case, but it is definitely on load that is not working. When I select another item then select it again, it works perfectly. Also, on new, it works perfectly, it is just when it is loaded on edit initially that it does not work. There are no errors being produced and the version before worked correctly. As soon as I updated to the newer version with the checkboxes for multi-select fields, it started asking inconsistent. Some items do load as expected, then some don’t.

    • #18578

      chgrnet
      Participant

      When I try to use version DFFS_2017-10-17, I have a really slow load time when I try to change the single select drop-down selection, and the issue from above still persists. It seems really random what it choses not to load on load. There are no errors when I debug, everything is loading/not loading as expect in debug. When I change the selection, it works correctly, using the same rule as is used for on load.

      I am not able to use DFFS_2017-10-17 due to the slow load time on change of the single-select choice field.

  • #18590

    Alexander Bautz
    Keymaster

    Is it the cascading dropdown plugin you are having trouble with? – I have had one other report on random failed loads of this plugin when using IE, but haven’t been able to recreate it.

    If it’s this plugin, cold you give me some more information about your SharePoiont and IE version? Also, approximately how many items do you have in the cascading dropdown source list?

    You should be able to use an older version of this plugin – try pulling it from an older DFFS package (in the DFFS_older_versions folder).

    Alexander

    • #18601

      chgrnet
      Participant

      No cascading dropdowns, out of the box single select drop-down. It only fails to work correctly on load, on select it works perfectly. I am using IE 11.

  • #18671

    Alexander Bautz
    Keymaster

    Sorry for the delay. Is this a choice column with a dropdown where all the options are defined in the list settings? – if so, how many options do you have in this dropdown choice?

    Alexander

  • #18673

    Alexander Bautz
    Keymaster

    Can you post a screenshot of the rule config and turn on debug on the rule and also include a screenshot of the debug output?

    Alexander

You must be logged in to reply to this topic.