"No value" issue

Forums Dynamic Forms for SharePoint "No value" issue

This topic contains 3 replies, has 2 voices, and was last updated by  Alexander Bautz 2 months, 1 week ago.

  • Author
    Posts
  • #21004

    chgrnet
    Participant

    I cannot say exactly which version this stopped working, but I have used the “no value” rule for quite some time. I do this by selecting the choice field “If this trigger”, is equal to, then not selecting any values. At some point late last year this rule stopped working on load. I can sometimes get it to work on field change, but only if I am not using radio buttons.

    I have spent hours on trying to figure out a way to get DFFS to recognize there is no value selected in a choice field. There are no errors, it just never sees that rule. I am working on NewForm right now, I need to re-test on EditForm to make sure it is happening there.

    This is how I tested it: I created a radio button field with 3 selections to load with no value. I create a rule that said it was equal to none of the values, and I put a message in place. When I go to the form, nothing happens.

    If this is supposed to work, if there is any way you can test this and see if there is another way to get it to work, I would really appreciate it.

  • #21022

    Alexander Bautz
    Keymaster

    Hi,
    Sorry for the late reply – This is supposed to work. I did a test now, and don’t have any problems setting this rule up.

    Which version of DFFS are you running?

    Alexander

    • #21088

      chgrnet
      Participant

      DFFS Backend v4.4.3.42|CSS version: 4.42 / 4.42|spjs-utility version: 1.323

  • #21112

    Alexander Bautz
    Keymaster

    OK, I need to see a few screenshots of your rule configuration and any other relevant information about your form to be able to set up a test. You can attach it to this post, or email it to me.

    Alexander

You must be logged in to reply to this topic.