DFFS with vLookup on Calendar with Content Approval

Forums Dynamic Forms for SharePoint DFFS with vLookup on Calendar with Content Approval

This topic contains 2 replies, has 2 voices, and was last updated by  Alexander Bautz 11 months ago.

  • Author
    Posts
  • #14952

    Kasey
    Participant

    I just updated my DFFS files to the current production version. I have a Calendar with Content Approval enabled that I was using DFFS 4.4.1.3 which was working as expected. After I upgraded I deleted the old CEWP web parts and used the installer. After that the DispForm still worked but EditForm stopped working. I reverted EditForm back to the CEWP files. It started working again but when I go into the backend there are no rules, tabs, etc but the form does have them. Here are all of my issues. Am I missing something or does some of this not work with Calendar or with Content Approval?

    EditForm stopped working. I get this took too long and when I click on the link I get a blank page. No errors in the console.

    DispForm does’t display configured vLookup column. No errors in the console.

    Version information: Frontend
    DFFS frontend: 4.4.2.2
    DFFS frontend CSS: 4.21 / 4.21
    Autocomplete: 1.4.12
    Cascading dropdowns: 3.6.1
    jQuery: 1.12.4
    Lookup: not loaded
    Resource management: not loaded
    SPJS-Utility: 1.270
    vLookup: frontend v2.2.79

    Version information: Backend
    DFFS Backend v4.4.2.2
    CSS version: 4.18 / 4.18
    spjs-utility version: 1.27
    vLookup: The vLookup plugin is not loaded. You must edit the DFFS loader file in “/SPJS/DFFS/loader/DFFS_Loader.html” to include it when loading DFFS.

  • #14954

    Kasey
    Participant

    On the issue with my EditForm no longer working.. the NewForm is having the same problem. I did find an error in the console and it appears to have something to do with Cascading Dropdowns.

    Object doesn’t support property or method ‘split’

    ;if(typeof spjs.casc!==”undefined”){if(spjs.casc.version.split(“.”).join(“”).substring(0,2)<spjs.dffs.backend.spjsCascMinVersion){alert(“[DFFS Plugin needs updating]\n\nThe Cascading dropdown plugin must be updated.

  • #14957

    Alexander Bautz
    Keymaster

    I just fixed this issue yesterday, but haven’t had time to update the full “package” – you find a link to the new version of the spjs-casc.js plugin here: http://spjsblog.com/forums/topic/cascading-dropdowns-creating-problems-on-editform-and-backend-config/#post-14945

    Alexander

You must be logged in to reply to this topic.